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About BYTE on CD-ROM
BYTE on CD-ROM contains the complete text of BYTE from 1990-1994, plus text and graphics from 1995
and future issues. 

The graphics viewing software is licensed from Accusoft.



Anatomy of the main window
The application runs in a single main window split in two panes: the table of contents pane, and the 
document pane. A slider adjusts the boundary between the two panes.

Toolbar buttons give access to common functions. If the cursor is on a toolbar button, the status bar 
reports its function. Otherwise, the status bar reports the issue, section, and title of the current document. 
The status bar also reports the number of documents found in a search, and the number of documents 
selected for print or export.

The title bar of the document pane reports the title of the current document.



Right mouse button controls
New with the Q3 1995 disc. Use the right mouse button to pop up a context-sensitive local menu. 

Related Topics:
From the table of contents pane you can:
From the document pane you can:



From the table of contents pane you can:
Fully expand the current node

Use the global level controls (1,2,3,4)

Toggle title hints

Clear a selection

Maximize the table of contents or document panes



From the document pane you can:
Change fonts

Toggle image dithering

Annotate the current article

Maximize the table of contents or document panes



Toolbar controls

The toolbar gives instant access to common functions:

Related Topics:

 Table of contents controls

 Window controls

 Search controls

 Document controls



 Table of contents controls
These buttons control the level of expansion of the table of contents:

1 - Issue level (e.g. December 1994)

2 - Section level (e.g. Reviews)

3 - Article level (e.g. Four Color Printers)

4 - Attachment level (tables, figures, photos)



 Window controls
 Maximize table of contents. Useful for viewing search results.

 Restore default view of table of contents and document.

 Maximize document. Useful for viewing large tables or graphics.



 Search controls
 Begin a new search. When complete, table of contents reduces to display only matching documents.

 Clear a search. Restore the table of contents to its normal, fully-expanded state. (Appears grayed 
unless a search is in effect.)



 Document controls
 Copy selected region of document to clipboard. (Appears grayed unless a region is selected.)

 Go to next document.

 Go to previous document.

 Go to next search hit.

 Go to previous search hit.

 Undo hypertext jump. (Appears grayed unless a hypertext link has been followed.)

 Print documents.

 Annotate the current document. (Appears "pushed in" if the current document already has an 
annotation attached to it.)



Menu controls

Related Topics:
File menu
Edit menu
Search menu
View menu
Options menu
Help menu



File menu
Print - First, you select what to print: documents (default) or the table of contents. If you ask to print 
documents, you then select either the current article (default), or the items checked in the table of 
contents, or all items shown in the table of contents. Click OK to print.

Print Setup - Select a new printer, or change the settings of the current printer.

Export - As with Print, first select whether to print documents or the table of contents. If documents, 
select current, marked, or all. Click OK to save the selection as an ASCII text file.

Exit - Exit BYTE on CD-ROM.



Edit menu
Copy - Copy a highlighted region of a document to the clipboard.

Clear Selection - Remove all checkmarks indicating documents selected for export or print.

Annotate - Attach a note to the current document. 

Goto annotation - Display the list of annotations. Click on an annotation to go to its associated 
document.



Search menu
New search - Begin a new search. When complete, the table of contents will reduce to display only those
documents found.

Clear search - Restore the table of contents to its original, fully-expanded state.

History - Display a list of searches performed during the current session. Click on an item to recall the 
configuration established by that previous search.

Previous document - Go back one document. 

Next document - Go forward one document.

Next hit - Go to the next paragraph containing a search hit, crossing document boundaries as needed.

Go back - Undo a hypertext jump.



View menu 
Switch pane - Change focus from the table of contents pane to the document pane, or vice versa.

Level 1 - Summarize table of contents by issue. (This is the default when there is no search in effect.) 
Useful for quickly identifying an issue of BYTE that matches a search.

Level 2 - Summarize table of contents by issue and section.

Level 3 - Summarize table of contents by issue, section, and document. (This is the default after a 
search.)

Level 4 - Show complete table of contents:    issues, sections, titles, documents, and attachments.

Split view - Allows keyboard control of the slider that separates the table of contents pane from the 
document pane. When the slider highlights, use the left and right arrow keys to move it, and use ENTER 
to set the new position.

Table of contents only - Expand the table of contents pane to the full width of the main window. Useful 
for browsing long titles.

Table of contents and document - Restore the normal two-pane display.

Document only - Expand the document pane to the full width of    the main window. Useful for viewing 
large images.



Options menu
Fonts - Adjust the fonts used for the text elements shown in the document pane.

Show toolbar - Toggle display of toolbar off, or back on.

Show status bar - Toggle display of status bar off, or back on.

Use image dithering - If your display supports more than 256 colors, turn this option off    for best-quality 
display of photographic images.

Show title hints - Toggles context-sensitive display of table-of-contents titles.



Help menu
Contents - View this help file.

Using help - View help about help.

About - Information about the developers of BYTE on CD-ROM.



About search
BYTE on CD-ROM supports Boolean search:

Ethernet and switch          PRI or BRI                Apple andnot Macintosh

phrase search:

switching hub

proximity search:

Ethernet within/30 switch

and wildcard search:

Ethernet within/30 switch*

You can also build more complex expressions using parentheses:

Apple within/10 (IBM or Motorola)

You can search just in document titles, or in the full text of documents and tables.

You can search the whole database from 1990 to the present or, for faster results, just the portion from 
1994 onward.

You can search all sections of BYTE (Reviews, State of the Art, What's New, etc.) or just selected 
sections.



Anatomy of the search dialog



Search techniques
To search effectively, you have to strike a balance between precision (finding only the articles you want) 
and recall (finding all the articles that might related to your search).

You'll also want to find articles as quickly as possible.

Related Topics:
Improving search precision
Improving search recall
Improving search speed



Improving search precision
Use proximity search -  If you want to find articles in which ISDN is closely associated with Internet, 
don't do this:

ISDN and Internet

Instead, do this:

ISDN within/30 Internet

which finds occurrences of ISDN within 30 words of Internet. Note that while the WITHIN button on the 
search dialog supplies 30 words as a default, you can be even more precise if you want:

ISDN within/10 Internet

Use phrase search - If you want to find articles on document management, don't do this:

document and management

Instead, do this:

document management

Use Include Sections - If you're looking for product information on laser printers, don't leave the search 
dialog at the default setting, which includes all the sections of BYTE. Instead, specify those sections likely
to contain product information: What's New, Reviews, BYTE Lab Product Report.

Use AndNot - If you're looking for articles that are about Apple Computer's non-Macintosh products and 
technologies (e.g., OpenDoc, LaserWriter, Newton) try this:

Apple andnot Macintosh

Use title search - If you're looking for articles that are about OS/2, as opposed to those that only mention
OS/2, click the Titles Only option in the search dialog.

Use table search - If you're looking for benchmarks or source code, click the Tables Only option in the 
search dialog.



Improving search recall
Use wildcard search - If you want to find articles that contain all of these phrases:

Ethernet switch                      switching Ethernet hub                    switched Ethernet

then do this:

Ethernet within/30 switch*

Note that only trailing wildcards will work.



Improving search speed
Use 1994-95 Only - If you're looking for recent articles, click this option on the search dialog. It's much 
faster to search just the 1994-95 part of the collection.

Use Title Search - It won't find as many articles as full text search, but it can be useful in some situations,
and it's much faster than full text search.

Use Halt And Keep Results So Far - Even if you haven't checked 95-94 Only, you can interrupt search 
at any point and retain all results found to that point. What's more, since search proceeds in reverse 
chronological order, what you keep if you halt search are the most recent matching articles. The progress 
meter shows where you are on the 1995-1990 time line, and how many articles you've found so far. Feel 
free to interrupt the search at any time! It's handy. Here's what it looks like:



About navigation
The table of contents gives random access to documents. It summarizes the complete document 
collection when there is no search in effect. When search is in effect, the table of contents summarizes 
the search results.

You can control the table of contents globally with the  buttons, or locally by opening and 
closing individual items.
You can control the table of contents locally by using the right-mouse-button menu to fully expand 
individual nodes.

Use the  and 

 buttons to step from article to article, and 

 or 

 to step from search hit to search hit.

 Click on underlined hypertext links to jump to tables or images. Use the  button to jump back.



Anatomy of the table of contents



Navigational techniques
Navigation always works the same way, whether or not a search is in effect    You single-click on issue-
level and section-level folders to open them, then single-click on the title of the article you want to read, 
print, or export. Or, single-click on the title of the image you want to view.

Related Topics:
Navigating search results
Navigating hypertext



Navigating search results
Usually, you'll be navigating a table of contents that has been reduced by search to a small number of 
articles. There are three ways to navigate the document collection:

Random access - Click on a document or attachment in the table of contents to jump to that item.

Sequential access by article - Use the Next Document and Previous Document controls. They're 
available three ways: on the toolbar, on the Edit menu, and on the F3 and F4 keys. When you go to a 
previous or next document, the table of contents pane automatically synchronizes with the document 
pane.

Sequential access by search hit - This is the most useful way to scan search results. Use the Next Hit 
and Previous Hit controls. They're available on the toolbar, the Edit menu, and the TAB/SHIFT-TAB keys. 
The cursor in the document pane moves from one paragraph containing a search hit to the next. When all
hits in one article are exhausted, Next Hit and Previous Hit automatically take you to the next or previous 
document, synchronizing the table of contents and document panes accordingly.



Navigating hypertext
Words and phrases underlined in the document pane are hypertext links. Click on a link to jump to a 
table, figure, photo, or illustration within the current article.

To undo a hypertext jump, use the Go Back function. It's available on the toolbar, the Edit menu, and the 
BACKSPACE key.



Selecting what to print or export
To accumulate a list of    documens to print or export, use the checkboxes at the left of the table of 
contents to mark those documents. (Clear Selection on the Edit menu empties that list.)

To begin a print operation, choose Print from the File menu, or click on the  toolbar button.
To begin an export operation, choose Export from the File menu.
In either case, the following dialog box appears:




